cnstream安装时安装依赖项libopencv-dev出现:libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) hairui2019-11-28 20:28:57 回复 查看 视频SDK 视频处理编程库 CNStream
cnstream安装时安装依赖项libopencv-dev出现:libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1)

从官网拉下cnstream源码后,在进行编译之前需要安装依赖项(依赖项及安装命令具体见 源码目录下的README文档)!在安装 

libopencv-dev 过程中,根据系统的设置,可能会出现缺少很多依赖库的问题,导致cmake不通过,无法编译!问题如下:

(作者出现问题的系统是ubuntu16.04)

执行命令如下:

sudo apt-get install libopencv-dev

提示错误:

The following packages have unmet dependencies:
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libhighgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libcvaux-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

如图:

安装linopencv-dev.jpg


解决方法:

这是由于系统的apt镜像源出了问题,应该更换回系统之前的镜像源!换回之后,需要重新进行编译,然后问题解决!

官方微博 官方微信
版权所有 © 2019 寒武纪 Cambricon 备案/许可证号:京ICP备17003415
关闭